„Joomla!” — po 8 latach odkryto lukę w uwierzytelnianiu LDAP

„Joomla!” to drugi na świecie najpopularniejszy system zarządzania treścią. Szacuje się, że opartych o CMS Joomla! jest ponad 3% wszystkich stron internetowych. Znaleziona podatność na pewno nie będzie jedną z najbardziej spektakularnych (trzeba spełnić dwa warunki), jednak dotyczy niemal wszystkich wersji: od 1.5 do 3.7.5 włącznie. Najnowsze wydanie 3.8, które zostało udostępnione 18 września, zawiera już łatkę naprawiającą opisywaną poniżej lukę.  

Podatność, która potencjalnie zagraża niemal wszystkim stronom internetowym zbudowanym przy wykorzystaniu CMS Joomla! została odkryta przez „zcustomizowane” rozwiązanie RIPS firmy RIPS Tech, opisywane także przez OWASP jako najbardziej popularne narzędzie do automatycznej analizy statycznego kodu pozwalające wykrywać podatności w aplikacjach PHP. Wspomniany RIPS wykrył nieznaną wcześniej lukę we wtyczce obsługującej protokół logowania LDAP.

Zdalny atak może skutecznie wyodrębnić poświadczenia uwierzytelniania serwera LDAP, które zostały wprowadzone podczas instalacji. Osoba atakująca, jeśli wykorzysta przechwycone informacje do zalogowania się do panelu administracyjnego, będzie miała pełny dostęp do zaatakowanej strony. Konsekwencje są trudne do przewidzenia.

Podatność CVE-2017-14596 dotyczy wersji Joomla! od 1.5 do 3.7.5 włącznie, ale od warunkiem, że skonfigurowano protokół LDAP. Zalecamy natychmiastową aktualizację. Najnowsza wersja 3.8 CMS-a Joomla! wnosi do rdzenia nie tylko poprawki łatające możliwość przeprowadzenia ataku odkrytego przez firmę RIPS Tech.




Komentarze

Obrazek użytkownika Krzysiu Myga

Ale jaja, właśnie dlatego korzystam z Drupala

Dodaj komentarz